Наверх

База знаний
Try 2 Fix
beta

Отключение автоматического обновления Mozilla Firefox

Отключение обновления Mozilla Firefox

Время банк-клиентов именно как приложений-клиентов уже прошло. Большая часть банков перешла на онлайн версии клиентов. Чаще всего в основе таких приложений лежит Java. Но настроить связку «Нужная версия Java» + «Нужная версия браузера» зачастую сложно. В большинстве случаев подходит браузер Mozilla Firefox. Всё работает, но потом Firefox обновляется и начинаются проблемы: то сама новая версия Firefox перестаёт поддерживать работу банк-клиентов, то новая версия блокирует старые версии Java Runtime Environment. А поскольку банк-клиенты не успевают за обновлениями Java, иногда нужно использовать именно более старые её версии. Рассказываем и показываем как отключить автоматическое обновление Mozilla Firefox.
 

Старые версии (абсолютно любые) можно найти на этом сайте: https://ftp.mozilla.org/pub/firefox/releases/

Допустим, нам нужна версия Firefox 43, загружаем её, устанавливаем.

Для того, чтобы отключить автоматическое обновление Mozilla Firefox необходимо:

  1. В адресной строке браузера набрать
    about:config

    и нажать Enter

  2. В открывшейся странице подтвердить, что Вы будете аккуратны. Внимание! Вам действительно нужно быть аккуратными! Неправильные действия могут сделать браузер неработоспособным!
  3. В строке Поиск (чуть ниже адресной строки) наберите
    app.update

    Настройки отфильтруются, останутся только те, которые начинаются с введённой фразы.

  4. Далее переключаем два параметра:
    • app.update.auto — автоматическое обновление браузера
    • app.update.enabled — обновление браузера

    Эти параметры имеют булевы значения (true/false). После двойного клика по каждому из них, текст в этих строчках станет жирным, состояние переключится на «Установлено пользователем», а значение станет false.

  5. Закройте браузер и откройте снова.
  6. После этих действий браузер перестанет обновляться в автоматическом режиме. А чтобы обновить его, откройте Меню (слева от адресной строки) > Нажмите на знак ? внизу > Выберите пункт «О Firefox» > В открывшемся окне нажмите на кнопку «Проверить обновления». После проверки на этой же кнопке появится предложение обновиться с номером версии.

Готово!

Эти статьи будут Вам интересны

1С:Предприятие и PostgreSQL: Размещение базы данных 1С за пределами хранилища PostgreSQL

Вносить какие-то глобальные изменения сразу в работающую базу данных 1С:Предприятие - дело неблагодарное. Даже если у Вас есть резервные копии, понадобится время, чтобы восстановить их, а время для некоторых организаций критично. Поэтому лучше проводить отладку своих обработок на копии базы данных. Если это файловая версия - вообще нет никаких проблем. Если SQL - всё немного сложнее. А если ещё и закончилось место в хранилище баз данных СУБД, а расширять хранилище нет места/возможности - то это вообще проблема. Но мы поможем!

Инструкция по защите Windows от уязвимостей Meltdown и Spectre

Статья обновлена 9 января 2018 в 22:22.  Добавлено видео. Год начался с отличных новостей об уязвимостях Meltdown и Spectre. Вот их список CVE-2017-5753 - Bounds check bypass CVE-2017-5715 - Branch target injection CVE-2017-5754 - Rogue data cache load Полностью защитить себя от них не получится, так как нет средств, которые полностью закрывают их, но IT гиганты уже начали латать эти дыры. Подавлюяющее большинство наших клиентов работают на Windows, поэтому мы подготовили инструкцию по защите Windows от уязвимостей Meltdown и Spectre. Это не исчерпывающее руководство, так как механизмов полного закрытия уязвимостей ещё не существует!

1С:Бухгалтерия базовая 3.0: Справочник. Организации. МодульМенеджера(1556); Ошибка при вызове метода контекста

При обновлении 1С:Бухгалтерии базовой с релиза 3.0.43.213 у пользователя возникла следующая проблема: на последнем этапе обновления появляется сообщение об ошибке следующего содержания: {Справочник.Организации.МодульМенеджера(1556)}: {Справочник.Организации.МодульМенеджера(1474)}: Ошибка при вызове метода контекста (ПолучитьОбъект) ТекущаяВерсияОбъект = ФайлИсточникОбъект.ТекущаяВерсия.ПолучитьОбъект(); по причине: Элемент не выбран! ВызватьИсключение ПодробноеПредставлениеОшибки(ИнформацияОбОшибке); При попытке обновиться до всевозможных релизов, начиная с 3.0.43.213 до 3.0.43.236 проблема повторяется. Внутреннее и внешнее тестирование не помогли, чистка кэша тоже. Обходим эту проблему иначе.